test161 runs successfully locally, boot.t fails on test161 submit?

I searched the forum and people suggested this issue could be because of the ramsize in sys161.conf but I have it set to 1M as per the test161 server. Any ideas as to why this would happen? Thanks in advance

By “fails on test161 submit”, do you mean on the server, or locally in your console before it passes it off to the server?

What does the output show, is your kernel panicking?

I figured out what I did, I changed my code and had a build that was working, and then when I pushed the git changes to submit, the new code was being tested. Is there any way to restore code from a build number? I had been looking for every solution to my problem and thus have no idea what was my working solution, if I could just get the files from the kernel-ASST3 that I backed up I would be fine but I don’t think that’s possible

You can use Git for that. I’d start with git diff to see what changed between commits. If you’re 100% sure you want to go back to a specific point, you can use git revert to undo commits. Assuming a clean working directory, you can also do git checkout <commit> to see the state of things at a certain point. (Note: this will put you in a detached HEAD state, and you’ll need to git checkout <branch>, (i.e. master), to get back. Just make sure you have all of your changes committed before you start mucking around with reverts and whatnot.

Thanks

I have my backup and am now passing again locally. I can confirm my local changes are synced with my repo if I try to run bmake depend, bmake, bmake install, no new builds are installed, confirming no changes have been made.

If I run git status I get…

On branch master
Your branch is up-to-date with ‘myorigin/master’.
nothing to commit, working directory clean

If I run git pull I get…

From github.com:edmundpf/os161

  • branch master -> FETCH_HEAD
    Already up-to-date.

This confirms my local repo is up to date with my git repository. So, if I run test161 locally I receive a 100/120, but if I try to submit I am not even able to boot. My sys161.conf is ramsize is set to 1M as well. I currently get a 0 via test161 submit and am not even able to boot but get that locally, any suggestions?

On the server or in your console? Also, try bmake clean also just to make sure.

ran ./config ASST3 from conf, ran ./config from os161 directory, bmake clean, bmake depend, bmake, bmake install from compile/ASST3, bmake depend, bmake clean, bmake, bmake install from os161 directory. Still 100/120 locally, 0 over test161. If I come to Davis can someone help me so I can get points?

EDIT: also ran git add .
git commit -a
git push myorigin master --force

Receive : everything up to date notification

git pull myorigin master

Receive : everything up to date notification

before running the tests

In my console

There’s staff in Davis now. I can come down in about 30 min if they can’t help resolve it.

I’d suggest cloning your repo into a separate directory, configuring, installing into a new root directory and trying it. (this is exactly what test161 is doing.) You should see the exact build steps at the top of the test161 submit output.

Alright sounds good thanks