[Resolved] Could not bind debug socket; debugging disabled


(Richard Salvatore Hanulewicz) #1

When I launch my kernel, the sockets fail to bind (both gdb and meter) and therefore I cannot connect os161-gdb to my kernel for debugging. Anyone have any idea why? I figured it might be a permissions thing so I also tried sudo. I’m using the Vagrant installation on Windows 10, already running as administrator to resolve symlink problems in the kernel install process.

trinity@zion:~/shared/root$ sys161 kernel
sys161: bind: Operation not permitted
sys161: Could not bind debug socket; debugging disabled
sys161: bind: Operation not permitted
sys161: Could not set up meter socket; metering disabled
sys161: System/161 release 2.0.8, compiled Jan  9 2017 17:17:19

(Blake Wallace Hurlburt) #2

I had this problem because I had installed os161 as root. I fixed it by reinstalling as my normal user, without sudo. Try running sys161 with sudo, and if that doesn’t work, you may need to reinstall os161.


(Geoffrey Challen) #3

Move your root directory out of the shared folder and you should be fine. sys161 needs to set up some special socket files and I suspect Windows isn’t allowing those to be created in the shared folder. (This will also interfere with test161 automated testing since we use the metering interface.)

There’s no real reason to share your root directory anyway, since you can’t run sys161 or test161 outside of the VM anyway.


(Richard Salvatore Hanulewicz) #4

Good call Geoff, worked like a charm. Thanks!


(Geoffrey Challen) #5

PS: you’ll have to rerun configure in root to tell it about the new root location. Being confused about where files are actually being installed to has flummoxed students in the past, so be careful!