Identical Source Trees Don't Produce Identical Kernels


(Junjie Wei) #1

so, i git pulled the code from my team repository, and i have the same code as my partner’s, but i dont know why he can pass his test in the kernel but i can’t, any ideas?


(Yousuf Zubairi) #2

Can you post the output from both yours and his?


(Benjamin Rueda) #3

This is just a shot in the dark but one possibility is that you’re not actually compiling your kernel into the directory that you think you are. When you run bmake install, verify that you actually installed a new executable into your root directory. If you truly have the same code as your partner then there’s not many possible explanations except for something silly like this.


(Junjie Wei) #4

i not sure how to verify if i actually installed a new executable into the root directory, so this is what showed up when i ran bmake install.


(Benjamin Rueda) #5

That looks ok. How sure are you that you and your partner have the same code? Do the git log and git status commands produce exactly the same output for both of you?


(Junjie Wei) #6

he was right next to me when he push up the code, and i also asked him to make sure if mine is same as his, we double checked and it is the same… so i am pretty sure


(Geoffrey Challen) #7

Make sure the kernels are identical: try using md5sum or something similar.

It also looks like your build is putting the new kernel into ~/os161/root/. Is this what you are expecting? If you are using a kernel in some other root directory (like ~/root/) then it is out of date. You need to reconfigure your base source tree.

Also please next time use an appropriate subject.


(Stephen James) #8

I’d recommend that you reconfigure for ASST1 (./config ASST1), then do both bmake depend and bmake, along with the things others above have suggested.


(Geoffrey Challen) #9

To make sure that it’s install to where you expect, you can also (a) blow away the kernel in your root directory and make sure that make install recreates it, or (b) check the hashes or timestamps of the kernel and the kernel from your compile directory.


(Junjie Wei) #10

ok, problem solved, so i basically blow away the kernel and bmake ASST1, and it worked. Thanks!!!