Deadlock Detector, wonky vm-stability


(Kedar Mohan Paranjape) #1

I am running into random “Monitor timed out after XX seconds” issues while running vm-stability. These are presumably because of parallelvm timing out. When run individually, every test that vm-stability runs succeeds(both in sys161 as well as via test161). To make sure they’re not the result of a deadlock, I’m trying to use the deadlock detector code. What is the correct way to use the following macros:

HANGMAN_LOCKABLEINIT
HANGMAN_WAIT
HANGMAN_ACQUIRE
HANGMAN_RELEASE

Currently, I have the these macros written in the corresponding lock_* methods. And so far there doesn’t seem to be a deadlock.

Also, I’m presuming this will detect every deadlock (since our locks/CVs etc are based off spinlocks).

On a related note, how would we go about solving the timeout issue for vm-stability?


(Geoffrey Challen) #2

You have to enable deadlock detection in the kernel configuration file. This is not on by default, and not currently used by test161.