badcall/opentest fails when running test161 suite


(Jaskirat Singh) #1

So, when i run badcall/opentest in kernel mode it runs fine but, if i use test161 run asst2, it says incorrect, i dont understand what the issue is here it passes all tests in kernel mode but it just doesnt like it when i run do use test161, my shelltest passes in test161


(Scott Haseley) #2

It’s hard to tell why without seeing the output. Can you post the relevant sections?

Also, test161 may be running with a different configuration, so make sure when you’re testing with sys161, you’re running with the same config. See this post for info.


(Jaskirat Singh) #3

I have pasted 2 images the first one is when it runs the dependency using test161 and the second is open badacall in kernel


(Zachary Scott Moore) #4

The test will run in shell mode on the test suite. Also you have to have argument passing completed with your execv in order for it to select the proper test.

One issue for me once the full execv call was done was vfs_open was not working in shell as a result of some directory lookup errors. However, your situation is most likely argument issues. Try to test argtest first.


(Scott Haseley) #5

As @zsmoore points out, the test is run from the shell. If you run

test161 run -explain stability/badcall/badcall-open.t

you’ll see that the command sequence is

boot
s
/testbin/badcall c

So, first I’d recommend trying that and making sure we’re comparing apples to apples. Also, make sure you run it with the same config. The test161 command in this post also outputs the config.

Finally, the reason the test failed was a monitor timeout – there was no progress for 10s – indicating that the test hung while running.